payloadcms-plugin-ecommerce

Ecosystem: npm

Downloads:

Vulnerabilities from the last (months)
  • 0CriticalAffects 0 versions
  • 1HighAffects 2 versions
  • 0MediumAffects 0 versions
  • 0ModerateAffects 0 versions
  • 0LowAffects 0 versions
Severity distribution (all time)
1vulnerability
  • Critical0 (0.0%)
  • High1 (100.0%)
  • Medium0 (0.0%)
  • Moderate0 (0.0%)
  • Low0 (0.0%)

Monthly breakdown

  • 1 vulnerabilities
    • Critical: 0
    • High: 1
    • Medium: 0
    • Moderate: 0
    • Low: 0

Vulnerabilities (1)

Known vulnerabilities affecting payloadcms-plugin-ecommerce, based on data from OSV.

Vulnerabilities affecting payloadcms-plugin-ecommerce
IDSeveritySummaryAffected versionsPublishedSource
GHSA-8r29-2mp2-pmrwHighPayload Ecommerce has an order confirmation validation issue## Impact When using the Stripe payment adapter, an order confirmation could be processed more than once under certain conditions. You are affected if: - You use `@payloadcms/plugin-ecommerce` with the Stripe payment adapter. Deployments that do not use the Stripe payment flow are not affected. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Ensure Stripe order confirmations can only be processed once. This is a temporary mitigation; upgrading to a patched version is recommended.
  • < 3.90.0
  • >= 4.0.0-canary.0, < 4.0.0-canary.34
GitHub (opens in a new tab)
  • GHSA-8r29-2mp2-pmrwHigh
    Payload Ecommerce has an order confirmation validation issue
    • < 3.90.0
    • >= 4.0.0-canary.0, < 4.0.0-canary.34

    ## Impact When using the Stripe payment adapter, an order confirmation could be processed more than once under certain conditions. You are affected if: - You use `@payloadcms/plugin-ecommerce` with the Stripe payment adapter. Deployments that do not use the Stripe payment flow are not affected. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Ensure Stripe order confirmations can only be processed once. This is a temporary mitigation; upgrading to a patched version is recommended.

    CVE: CVE-2026-105850

Showing 1-1 of 1 vulnerabilities