hulumi-drift

Ecosystem: npm

Downloads: 181

Vulnerabilities from the last (months)
  • 0CriticalAffects 0 versions
  • 2HighAffects 2 versions
  • 0MediumAffects 0 versions
  • 0ModerateAffects 0 versions
  • 0LowAffects 0 versions
Severity distribution (all time)
2vulnerabilities
  • Critical0 (0.0%)
  • High2 (100.0%)
  • Medium0 (0.0%)
  • Moderate0 (0.0%)
  • Low0 (0.0%)

Monthly breakdown

  • Critical
  • High
  • Medium
  • Moderate
  • Low
  • 1 vulnerabilities
    • Critical: 0
    • High: 1
    • Medium: 0
    • Moderate: 0
    • Low: 0
  • 1 vulnerabilities
    • Critical: 0
    • High: 1
    • Medium: 0
    • Moderate: 0
    • Low: 0

Vulnerabilities (2)

Known vulnerabilities affecting hulumi-drift, based on data from OSV.

Vulnerabilities affecting hulumi-drift
IDSeveritySummaryAffected versionsPublishedSource
GHSA-32g3-35g9-wc9gHigh@hulumi/drift: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts**Affected:** `@hulumi/drift` `< 1.4.0` — **Fixed in:** `1.4.0` — **Severity:** Medium — **CWE-755 (Improper Handling of Exceptional Conditions)** #### Summary `@hulumi/drift` runs four adapters that each ask a different question about whether a resource has drifted (Pulumi-state diff, provider-version change, CloudTrail event, etc.). A classifier combines the adapters' answers into a verdict like `None / none`, `ConsoleBreakGlass / high`, or `Mixed / high`, and caches the verdict for 6 hours by default. Two related bugs from one root cause — the classifier only read each adapter's `detecte
  • < 1.4.0
GitHub (opens in a new tab)
GHSA-2ffm-hxrq-qqmmHigh@hulumi/drift: Orphan reconciler accepted externally supplied execute plansImpact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted. Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage. Remediation: upgrade @hulumi/drift to 1.3.2 or later.
  • < 1.3.2
GitHub (opens in a new tab)
  • GHSA-32g3-35g9-wc9gHigh
    @hulumi/drift: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts
    • < 1.4.0

    **Affected:** `@hulumi/drift` `< 1.4.0` — **Fixed in:** `1.4.0` — **Severity:** Medium — **CWE-755 (Improper Handling of Exceptional Conditions)** #### Summary `@hulumi/drift` runs four adapters that each ask a different question about whether a resource has drifted (Pulumi-state diff, provider-version change, CloudTrail event, etc.). A classifier combines the adapters' answers into a verdict like `None / none`, `ConsoleBreakGlass / high`, or `Mixed / high`, and caches the verdict for 6 hours by default. Two related bugs from one root cause — the classifier only read each adapter's `detecte

    CVE: CVE-2026-48036

  • GHSA-2ffm-hxrq-qqmmHigh
    @hulumi/drift: Orphan reconciler accepted externally supplied execute plans
    • < 1.3.2

    Impact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted. Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage. Remediation: upgrade @hulumi/drift to 1.3.2 or later.

    CVE: CVE-2026-82858

Showing 1-2 of 2 vulnerabilities