frontmcp

Ecosystem: npm

Downloads: 13.05 K

Vulnerabilities from the last (months)
  • 0CriticalAffects 0 versions
  • 1HighAffects 1 version
  • 0MediumAffects 0 versions
  • 0ModerateAffects 0 versions
  • 0LowAffects 0 versions
Severity distribution (all time)
1vulnerability
  • Critical0 (0.0%)
  • High1 (100.0%)
  • Medium0 (0.0%)
  • Moderate0 (0.0%)
  • Low0 (0.0%)

Monthly breakdown

  • 1 vulnerabilities
    • Critical: 0
    • High: 1
    • Medium: 0
    • Moderate: 0
    • Low: 0

Vulnerabilities (1)

Known vulnerabilities affecting frontmcp, based on data from OSV.

Vulnerabilities affecting frontmcp
IDSeveritySummaryAffected versionsPublishedSource
GHSA-65h7-9wrw-629cHighFrontMCP and mcp-from-openapi have bypass of OpenAPI external $ref SSRF fix## Summary The published fix for GHSA-v6ph-xcq9-qxxj / CVE-2026-39885 added a direct hostname denylist for OpenAPI external `$ref` dereferencing, but the latest patched dependency `mcp-from-openapi` 2.3.0 still makes backend-origin requests to loopback when the target is reached through hostname resolution, redirects, or IPv4-mapped IPv6 syntax. FrontMCP latest release v1.2.1 and current main still call `OpenAPIToolGenerator.fromURL()` and `OpenAPIToolGenerator.fromJSON()` from `mcp-from-openapi` 2.3.0 when loading OpenAPI adapters. An attacker who can cause a hosted or multi-user FrontMCP d
  • >= 1.2.1, < 1.5.0
GitHub (opens in a new tab)
  • GHSA-65h7-9wrw-629cHigh
    FrontMCP and mcp-from-openapi have bypass of OpenAPI external $ref SSRF fix
    • >= 1.2.1, < 1.5.0

    ## Summary The published fix for GHSA-v6ph-xcq9-qxxj / CVE-2026-39885 added a direct hostname denylist for OpenAPI external `$ref` dereferencing, but the latest patched dependency `mcp-from-openapi` 2.3.0 still makes backend-origin requests to loopback when the target is reached through hostname resolution, redirects, or IPv4-mapped IPv6 syntax. FrontMCP latest release v1.2.1 and current main still call `OpenAPIToolGenerator.fromURL()` and `OpenAPIToolGenerator.fromJSON()` from `mcp-from-openapi` 2.3.0 when loading OpenAPI adapters. An attacker who can cause a hosted or multi-user FrontMCP d

    CVE: CVE-2026-59973

Showing 1-1 of 1 vulnerabilities