backstage-plugin-search-backend-module-elasticsearch
Ecosystem: npm
Downloads: 55.12 K
- 0CriticalAffects 0 versions
- 0HighAffects 0 versions
- 0MediumAffects 0 versions
- 1ModerateAffects 1 version
- 0LowAffects 0 versions
- Critical0 (0.0%)
- High0 (0.0%)
- Medium0 (0.0%)
- Moderate1 (100.0%)
- Low0 (0.0%)
Monthly breakdown
- 1 vulnerabilities
- Critical: 0
- High: 0
- Medium: 0
- Moderate: 1
- Low: 0
Vulnerabilities (1)
Known vulnerabilities affecting backstage-plugin-search-backend-module-elasticsearch, based on data from OSV.
| ID | Severity | Summary | Affected versions | Published | Source |
|---|---|---|---|---|---|
| GHSA-9325-vq29-gp3v | Moderate | Backstage has incorrect authorization in search engine permission filtering### Impact An authenticated Backstage user subject to a `DENY` policy for search document types could receive search results they were not authorized to view. This affects deployments with `permission.enabled: true` and an Elasticsearch or OpenSearch search backend. ### Patches - Upgrade `@backstage/plugin-search-backend` to 2.1.6 - Upgrade `@backstage/plugin-search-backend-module-elasticsearch` to 1.8.7 ### Workarounds If you are unable to upgrade immediately: - Temporarily modify permission policies to use `CONDITIONAL` decisions with per-result filtering rather than blanket `DENY` for |
| GitHub (opens in a new tab) |
- GHSA-9325-vq29-gp3vModerateBackstage has incorrect authorization in search engine permission filtering
< 1.8.7
### Impact An authenticated Backstage user subject to a `DENY` policy for search document types could receive search results they were not authorized to view. This affects deployments with `permission.enabled: true` and an Elasticsearch or OpenSearch search backend. ### Patches - Upgrade `@backstage/plugin-search-backend` to 2.1.6 - Upgrade `@backstage/plugin-search-backend-module-elasticsearch` to 1.8.7 ### Workarounds If you are unable to upgrade immediately: - Temporarily modify permission policies to use `CONDITIONAL` decisions with per-result filtering rather than blanket `DENY` for
CVE: CVE-2026-106562