backstage-plugin-search-backend

Ecosystem: npm

Downloads: 534.73 K

Vulnerabilities from the last (months)
  • 0CriticalAffects 0 versions
  • 0HighAffects 0 versions
  • 0MediumAffects 0 versions
  • 1ModerateAffects 1 version
  • 0LowAffects 0 versions
Severity distribution (all time)
1vulnerability
  • Critical0 (0.0%)
  • High0 (0.0%)
  • Medium0 (0.0%)
  • Moderate1 (100.0%)
  • Low0 (0.0%)

Monthly breakdown

  • 1 vulnerabilities
    • Critical: 0
    • High: 0
    • Medium: 0
    • Moderate: 1
    • Low: 0

Vulnerabilities (1)

Known vulnerabilities affecting backstage-plugin-search-backend, based on data from OSV.

Vulnerabilities affecting backstage-plugin-search-backend
IDSeveritySummaryAffected versionsPublishedSource
GHSA-9325-vq29-gp3vModerateBackstage has incorrect authorization in search engine permission filtering### Impact An authenticated Backstage user subject to a `DENY` policy for search document types could receive search results they were not authorized to view. This affects deployments with `permission.enabled: true` and an Elasticsearch or OpenSearch search backend. ### Patches - Upgrade `@backstage/plugin-search-backend` to 2.1.6 - Upgrade `@backstage/plugin-search-backend-module-elasticsearch` to 1.8.7 ### Workarounds If you are unable to upgrade immediately: - Temporarily modify permission policies to use `CONDITIONAL` decisions with per-result filtering rather than blanket `DENY` for
  • < 2.1.6
GitHub (opens in a new tab)
  • GHSA-9325-vq29-gp3vModerate
    Backstage has incorrect authorization in search engine permission filtering
    • < 2.1.6

    ### Impact An authenticated Backstage user subject to a `DENY` policy for search document types could receive search results they were not authorized to view. This affects deployments with `permission.enabled: true` and an Elasticsearch or OpenSearch search backend. ### Patches - Upgrade `@backstage/plugin-search-backend` to 2.1.6 - Upgrade `@backstage/plugin-search-backend-module-elasticsearch` to 1.8.7 ### Workarounds If you are unable to upgrade immediately: - Temporarily modify permission policies to use `CONDITIONAL` decisions with per-result filtering rather than blanket `DENY` for

    CVE: CVE-2026-106562

Showing 1-1 of 1 vulnerabilities