backstage-plugin-scaffolder-backend-module-sentry

Ecosystem: npm

Downloads: 10.02 K

Vulnerabilities from the last (months)
  • 0CriticalAffects 0 versions
  • 1HighAffects 1 version
  • 0MediumAffects 0 versions
  • 0ModerateAffects 0 versions
  • 0LowAffects 0 versions
Severity distribution (all time)
1vulnerability
  • Critical0 (0.0%)
  • High1 (100.0%)
  • Medium0 (0.0%)
  • Moderate0 (0.0%)
  • Low0 (0.0%)

Monthly breakdown

  • 1 vulnerabilities
    • Critical: 0
    • High: 1
    • Medium: 0
    • Moderate: 0
    • Low: 0

Vulnerabilities (1)

Known vulnerabilities affecting backstage-plugin-scaffolder-backend-module-sentry, based on data from OSV.

Vulnerabilities affecting backstage-plugin-scaffolder-backend-module-sentry
IDSeveritySummaryAffected versionsPublishedSource
GHSA-g734-fhp4-7mfpHighBackstage: Improper input validation in Sentry scaffolder actions### Impact An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. ### Patches Upgrade `@backstage/plugin-scaffolder-backend-module-sentry` to version `0.3.8` or later. The fixed package is available in [Backstage v1.54.8](https://github.com/backstage/backstage/releases/tag/v1.54.8) and [Backstage v1.55.0](https://github.com/backstage/backstage/releases/tag/v1.55.0). The update
  • >= 0.3.0, < 0.3.8
GitHub (opens in a new tab)
  • GHSA-g734-fhp4-7mfpHigh
    Backstage: Improper input validation in Sentry scaffolder actions
    • >= 0.3.0, < 0.3.8

    ### Impact An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. ### Patches Upgrade `@backstage/plugin-scaffolder-backend-module-sentry` to version `0.3.8` or later. The fixed package is available in [Backstage v1.54.8](https://github.com/backstage/backstage/releases/tag/v1.54.8) and [Backstage v1.55.0](https://github.com/backstage/backstage/releases/tag/v1.55.0). The update

    CVE: CVE-2026-106459

Showing 1-1 of 1 vulnerabilities